Issue:
When starting an Autodesk 2020 or newer product on Windows, after several seconds a message such as the following appears and the program must close. The message may also appear after waking up from sleep mode.
License checkout timed out. What do you want to do?

Causes:
- Autodesk Desktop Licensing Service is not running.
- Corrupt Licensing Component.
- Corrupt Single Sign On Component.
- Incompatible 3rd party software/device.
- Product license registration incomplete
- Proxy or Network Setting.
Solution:
Recommended - Try the Troubleshooting Tool.
Basic Checks
Update the Autodesk Desktop Licensing Service and the Autodesk Single Sign On Component
In the majority of cases, this issue is resolved by applying the latest updates for
- Autodesk Desktop Licensing Service
- Autodesk Single Sign On Component (AdSSO)
Refer to the below table for reference. Visit the correspondent AKN page for each update for detailed install steps and information.
Update | Additional notes | Download from |
Autodesk Desktop Licensing Service | Important: | |
Autodesk Single Sign On Component (AdSSO) | - |
If the above solution did not help, see below more advanced troubleshooting. Test the software after each:
Verify that the Autodesk Desktop Licensing Service is running
See How to check the status of Autodesk Desktop Licensing Service.
Uninstall and Reinstall the Autodesk Desktop Licensing Service
Follow these steps:- How to uninstall Autodesk Desktop Licensing Service.
- How to download and install Autodesk Desktop Licensing Service.
Add Licensing Component to your antivirus exception list
Consult with your local IT team or Internet security application vendor to set exceptions in your antivirus software for the below folders.
- C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing\Current\AdskLicensingService\ (including all sub-folders and files).
- C:\Program Files\Autodesk\Autodesk AdSSO\AdSSO.exe